On the other hand on DEs like LXDE, compositing is not available by default. By changing KDE's System Settings. Flickering in fullscreen when compositing is enabled. With this setting enabled, most fullscreen games will suspend the compositor … And before you ask, no, the "disable compositor for fullscreen windows" is disabled, and this happen with mpv on windowed mode! In System Settings > Display and Monitor > Compositor, uncheck Enable compositor on startup and restart Plasma. After the upgrade i found that playing some video with mpv disable the kwin compositor. This command will disable compositing in the kwinrc config file: kwriteconfig --file kwinrc --group Compositing --key Enabled false Then restart kwin (in Alt+F2) with: kwin --replace To get compositing back, just substitute false with true and restart kwin again. Disable compositing. eg. In System Settings > Display and Monitor > Compositor, uncheck Allow applications to block compositing. I also tried to shut the machine to sleep mode while running the desktop effects. Another issue about KDE 4.5: kdm doesn't save the last logged in user anymore. Kde 5.6 is giving me some headache. Open System Settings > Workspace Behavior > Desktop Effects and disable individual effects with animations that you don't want. Press Alt + F3 to create a new kwin rule (with the game window selected) #2 Showing 1 - 2 of 2 comments From the favorites tab in klauncher, open "Configure Desktop", select "Desktop Effects", then uncheck the checkbox that is called "Enable desktop effects at startup". If turning off compositing fixes the micro-stuttering, verify that System Settings -> Hardware -> Display and Monitor -> Compositor -> “Allow applications to block compositing” is enabled. You will still have compositing active. You should see your rounded corners instantly come back after pressing that key combo. Many apps require compositing for proper working. It flickers extremly. Screen tearing with NVIDIA If I follow you correctly, you can press Shift-Alt-F12 to turn Kwin compositing back on. This may harm performance. Docky. 2-Add “Allow applications to disable compositing” in settings, and enable it by default. From the same screen, you can define a shortcut to enable/disable compositing anytime. To disable your compositor, click “Menu -> Preferences -> Windows.” This will open a new window called “Window Preferences.” Under the General tab, uncheck the box that says “Enable software compositing window manager.” With the compositor disabled, open a terminal and try running Compton. When the machine wakes up, the rendering looks even more broken. I too have been seeing compositing shutting off quite a bit, but I figured it had to do with me running Kodi (with compositing shut-off for that app). After some time, KDE just disables compositing due to "slow performance". Disable compositing permanently or temporarily in the KDE settings, via the assigned hotkey (normally Shift + Alt + F12) or via a script. For people like me having issues with this: in KDE you can create a kwin rule to ignore such a thing and force compositing to stay as it was.